Install-Package 那点事儿

By | 2013年12月3日

为了练习使用SignaR,新建了一个.net 4.0的MVC4项目, 第一步,不用说就是先将SignaR安装到项目中,考虑到SignaR 目前已经更新到2.0 并且无法在 4.0框架下面使用,此时通过Nuget 管理工具去安装的话,默认是安装最新版本的程序集。然后问题就来了…

问题一:不使用Package管理工具如何安装Package呢?
答:使用Package Manager Console.

问题二: 如何安装特定版本的程序集?
答: 在 Package Manager Console 中使用 带参数的 Install-Package 命令
通过  TooLS -> Libary Manager Console -> Package Manager Console 即可打卡面板。
输入Install-Package Microsoft.AspNet.SignalR -Version 1.1.0(使用SignaR 1.1.0 为例子)

问题三:如何卸载特定的Package呢?
答:使用 Uninstall-Package 命令
例如:Uninstall-Package Microsoft.AspNet.SignalR -Version 1.1.0

问题四:指定项目
答:使用-Project
例如:Install-Package Moq -Project SportsStore.Domain(项目名称)

郁闷的事儿
我在安装过成中,第一次SignaR2.0在.net4.0下安装失败。
第二次安装失败,错误提示:The remote name could not be resolved:’www.nuget.org’。
尼玛,nuget.org罢工了,洗洗睡了。

One thought on “Install-Package 那点事儿

  1. Pingback: 【转载】NuGet管理 | OnLoad

发表评论